Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Problem with wicd

  1. #1
    Just burned his ISO imported_h4x0r's Avatar
    Join Date
    Mar 2006
    Posts
    18

    Default Problem with wicd

    hello,

    i'v the problem, that wicd not brings up a connection. i checked the syslog and there are dhclient entries like "no such device". i manually connected to a wlan. i setted up some variables with iwconfig and startet dhclient manually. after them wicd checks, that i'm connected. if i have time i will figure out more about this and post more infos. i dont know if it is a bt4 or a wicd bug sry.

  2. #2
    Member
    Join Date
    Jan 2010
    Posts
    81

    Default

    menu --> services --> NETWORK --> start-network

    start wicd

  3. #3
    Just burned his ISO imported_h4x0r's Avatar
    Join Date
    Mar 2006
    Posts
    18

    Default

    Quote Originally Posted by ozzy66 View Post
    menu --> services --> NETWORK --> start-network

    start wicd

    thanks for the fast replie. i think i did it but i will do a test again. it's possible that i startet wicd before i started the network.

    [Update]
    i tested it again and it works with the resolution from ozzy66. thx
    @wpalin: it is importand to start wicd at this way? not from the menu? when i trie to start wicd from the menu before i start the network then nothing happens. i trie your cmd at next boot. thx

  4. #4
    Member imported_vvpalin's Avatar
    Join Date
    Apr 2009
    Posts
    442

    Default

    This is not an issue at all with wicd.

    boot
    /etc/init.d/wicd start
    under internet choose wicd settings manager


    Everything will be fine, you dont need to do all the other stuff if your using wicd.
    Using backtrack for the first time is like being 10 years old again with the keys to a Ferrari.

  5. #5
    Senior Member orange's Avatar
    Join Date
    Jan 2010
    Posts
    134

    Default

    From my perspective, the best way to solve the wicd "issue" permanently (at least for persistent LiveUSB) is the following: At first boot I type the following in that particular order:
    Code:
    # update-rc.d wicd defaults
    # /etc/init.d/wicd start
    # startx
    The wicd-client will start automatically with the KDE session IF the daemon got started beforehand AND with every subsequent boot-up, the daemon (and therefore also wicd-client) is started automatically. Just my 2c!

  6. #6
    Tom Hurley
    Guest

    Default

    what interface are you using?

  7. #7
    Just burned his ISO imported_h4x0r's Avatar
    Join Date
    Mar 2006
    Posts
    18

    Default

    if u asked me Tom Hurley then the answer is the following:
    eth1 (there r no problems)
    wlan0 (atheros -> Dlink DWG-650)
    i have still problems to connecting to WEP-wlans with wlan0. i cant use wicd....i set up all manually and connect manually. it's no problem cause i wrote a bash for all the wlan's.
    with WPA and wicd is no problem.
    i will post the log's for this issue this week.

    [Update]
    ok i'v tested it again. i did the following steps:
    Services->Network->Start Network
    Internet->wicd
    in wicd i choose a WEP encrypted one. No Connection. here the syslog:
    Jul 23 23:02:15 bt dhclient: Internet Systems Consortium DHCP Client V3.1.1
    Jul 23 23:02:15 bt dhclient: Copyright 2004-2008 Internet Systems Consortium.
    Jul 23 23:02:15 bt dhclient: All rights reserved.
    Jul 23 23:02:15 bt dhclient: For info, please visit http://www.isc.org/sw/dhcp/
    Jul 23 23:02:15 bt dhclient:
    Jul 23 23:02:15 bt dhclient: wmaster0: unknown hardware address type 801
    Jul 23 23:02:15 bt dhclient: wmaster0: unknown hardware address type 801
    Jul 23 23:02:15 bt dhclient: Bind socket to interface: No such device
    Jul 23 23:02:15 bt kernel: ADDRCONF(NETDEV_UP): wlan0: link is not ready
    Jul 23 23:02:16 bt kernel: wlan0: authenticate with AP XX:XX:XX:XX:XX:XX
    Jul 23 23:02:16 bt kernel: wlan0: privacy configuration mismatch and mixed-cell disabled - disassociate
    Jul 23 23:02:16 bt kernel: wlan0: authenticated
    Jul 23 23:02:16 bt kernel: wlan0: associate with AP XX:XX:XX:XX:XX:XX
    Jul 23 23:02:16 bt kernel: wlan0: mismatch in privacy configuration and mixed-cell disabled - abort association
    Jul 23 23:02:16 bt kernel: wlan0: privacy configuration mismatch and mixed-cell disabled - disassociate

    i looked what iwconfig says....it sets the essid but not the key (it is surly configured in wicd. i tried the diffrent options too)....
    wlan0 IEEE 802.11bg ESSID:"anAP"
    Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
    Tx-Power=27 dBm
    Retry min limit:7 RTS thrff Fragment thr=2352 B
    Encryption keyff
    Power Managementff
    Link Quality:0 Signal level:0 Noise level:0
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:0 Missed beacon:0

    after them i tried succesfully to connect to a WPA.
    when i set the HEX-Key with iwconfig and do dhclient i can connect to the WEP encrypted ones.

  8. #8
    Just burned his ISO
    Join Date
    Aug 2008
    Posts
    10

    Default

    @H4x0r
    im having the same issue but with WPA2.. havent tried with WPA though.. will update on this.

    But i have no trouble connecting with WEP on wicd, with a default HD install of PreFinal...

    any tip on how to overcome this ?

  9. #9
    Junior Member najib's Avatar
    Join Date
    Jul 2008
    Posts
    52

    Wink

    Quote Originally Posted by or4n9e View Post
    From my perspective, the best way to solve the wicd "issue" permanently (at least for persistent LiveUSB) is the following: At first boot I type the following in that particular order:
    Code:
    # update-rc.d wicd defaults
    # /etc/init.d/wicd start
    # startx
    The wicd-client will start automatically with the KDE session IF the daemon got started beforehand AND with every subsequent boot-up, the daemon (and therefore also wicd-client) is started automatically. Just my 2c!
    It seems very nice solution but,
    in case I want to come back to the way the network started before , how can I do ?

    NjB

  10. #10
    Just burned his ISO
    Join Date
    Apr 2009
    Posts
    1

    Thumbs up

    Quote Originally Posted by or4n9e View Post
    From my perspective, the best way to solve the wicd "issue" permanently (at least for persistent LiveUSB) is the following: At first boot I type the following in that particular order:
    Code:
    # update-rc.d wicd defaults
    # /etc/init.d/wicd start
    # startx
    The wicd-client will start automatically with the KDE session IF the daemon got started beforehand AND with every subsequent boot-up, the daemon (and therefore also wicd-client) is started automatically. Just my 2c!
    Man, you got no idea how long I been trying to do that... I feel like a bloody tool for overlooking that. I guess assumption IS the mother of all f***ups.
    Dont get me wrong, everything all configured great, just got real sick of /etc/init.d/wicd start or /etc/init.d/networking start at EVERY boot. (either worked fine).

    So kudos mate, you've just made my life a lot easier and saved some blisters on my fingers

    Oh, cause I ain't a real big forum-poster either, I'll just say thanks guys for Backtrack. Its bloody great! Also BIG thanks to all the guys that write such concise tutes on all manner of subjects in this forum, you have all been a big help as well.

    Cheers.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •