Results 1 to 9 of 9

Thread: Problem with persistent filesystem

  1. #1
    Junior Member
    Join Date
    May 2007
    Posts
    40

    Default Problem with persistent filesystem

    hi i got a problem I make a bt stick like in the video tut. I use the 5th menu option to edit the system and so on. But wehen i use the default option to boot then no change is ther. Is ther a way to use the changed backtrack but all aditional changes get lost until i boot the 5th option in grub to add more changes?

    I need a mode were i can do changes and one were i use a changed system but changes in this mode should be forget after shutdown.

    Greetz

  2. #2
    Senior Member orange's Avatar
    Join Date
    Jan 2010
    Posts
    134

    Default

    What you're trying to achieve isn't possible from my perspective. You have two options though:

    1. Change the system and built a "customized" iso with remastersys you can afterwards boot without changes. remastersys is part of BT4 pre-final. Please search the web how to use it.
    2. Customize the iso image within a chroot environment. muts provided a user-friendly script to do this over at the Offensive Security Blog.

    HTH orange

  3. #3
    Junior Member
    Join Date
    Mar 2009
    Posts
    39

    Default

    change the "default 5" to "default 4" in the menu.lst in the grub boot file from the tut. they kinda forgot about the zero variable...

    this should boot backtrack into persistents mode...ignore "or4n9e" fix...just a waste of time...
    They ran this hack in V.M.O., so I'm isolating the A.P.I., and just booting the host. -Matthew Farrell

  4. #4
    Senior Member orange's Avatar
    Join Date
    Jan 2010
    Posts
    134

    Default

    @war10ck216
    No offense intended, but have you even read *YAPP*'s question?

  5. #5
    Member floyd's Avatar
    Join Date
    Mar 2009
    Posts
    231

    Default

    @YAPP: Stop double posting. http://forums.remote-exploit.org/anf...tml#post140460
    Your question in the german forum was very unclear, that was the reason I couldn't help you. But you didn't even respond.
    Auswaertsspiel

  6. #6
    Just burned his ISO
    Join Date
    Jul 2009
    Posts
    1

    Default

    I myself am having the same problem, I am new to the whole booting from a USB thumb drive, but I've been running Slackware for almost 9 years now. This whole persistent deal is confusing. I followed the video also, and it was pretty clear, and mentioned that persistents would work.

    Step by step, and still when I make a change and reboot, it doesn't want to save. war10ck216: I see your reply but It doesn't make sense how that would turn on persistent. I really appreciate everyone's help.

  7. #7
    Junior Member
    Join Date
    May 2007
    Posts
    40

    Default

    Yeah I forgot about the 0 but it is not so importen.

    It seam that ther is no way to do what i want to do.

  8. #8
    Junior Member
    Join Date
    Mar 2009
    Posts
    39

    Default

    ...no point in helping out the files that are writin on persistents mode is saved in the casper-rw partiton.

  9. #9
    Member floyd's Avatar
    Join Date
    Mar 2009
    Posts
    231

    Default

    Quote Originally Posted by war10ck216 View Post
    It will turn persistent changes on by making the persistent mode the default on boot from usb drive. When u change the default value from 0 to 5 it will go from the first selection down to the texting mode selection. If you are going off of the video. Since the persistent mode is above the texting mode. you have to count the variable zero as a selection, so you have to change the default value from 0 to 4. then it will boot on persistent mode on boot up from usb drive. (this is changing the default in the menu.lst in the /boot/grub folder from the tut. on the backtrack site under resources)
    That won't solve his problem. Read the OPs post again.
    Auswaertsspiel

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •