Results 1 to 5 of 5

Thread: USB Install Persistent

  1. #1
    Just burned his ISO
    Join Date
    Apr 2009
    Posts
    5

    Default USB Install Persistent

    Hello,

    I am trying to install BT4 onto a USB. I have done so by copying the Boot and BT4 folders from the ISO file to a fat32 partition then running the bootinst.sh in Ubuntu 9.04 and also tried running bootinst.bat in WinXP. Also I have tried using Unetbootin by copying the ISO image to a fat32 partition on my USB.
    I was able to boot to BT4 successfully, however durning startup the "Activating swapfile" fails. This annoys me for 1. because the "Activating Swapfile" is OK when I boot from a CD but if I boot from the USB in either of the 3 ways I created the USB from above I can't get the "Activating swapfile" to be OK.
    I tried partitioning my USB in different ways 1.1 fat32 partition then the rest is ext2. 2. fat32 partition, then with a linux extended partition which was made up of an ext2 and linux-swap. 3. Also tried creating a fat32, then a second parition ext2 then a seperate third as linux-swap. 4. Partitioned the whole drive as linux extended and put in a fat32 and an ext2 and a linux-swap inside.
    I still can't get the damn "activating swapfile" to be successful. BT4 seems to work even though it fails but I don't like it. Plus i don't understand how a read-only DVD can have the swapfile successful but a writeable flash drive fails. I would like to understand how this is so but I couldn't find any info. As I don't like posting in forums.
    Also I know that flash drives have limited read/writes but that's beside the point.
    My last resort now is to boot from the CD then treat my flash drive as a HDD and set it up like it's a single boot install.
    If anyone has any info on the swapfile please let me know. Again I want to mention the the Activating swap is succesfull in all cases but just the "activating swapfile" fails when booting from the usb.
    Thanks

  2. #2
    Good friend of the forums
    Join Date
    Feb 2009
    Posts
    356

    Default

    when booting from CD, press TAB at the boot option and see what the swap option is in syslinux.cfg.
    set the same to be in your usb boot setting. (i.e. syslinux.cfg in your usb boot folder). That should do it.

  3. #3
    Just burned his ISO
    Join Date
    Apr 2009
    Posts
    5

    Default

    When I boot from the CD there isn't a swap option. Also the same syslinux.cfg is used when I boot from the CD or when I boot from usb.
    The only difference I can tell when I boot from a CD rather than from usb is that the file system on the CD is ISO6687 (4 numbers after ISO that I can't remember). And when I boot from the usb it is using a fat32 filesystem. Could that bee the problem?

  4. #4
    My life is this forum Barry's Avatar
    Join Date
    Jan 2010
    Posts
    3,817

    Default

    Is this an external usb drive or thumb drive? If it's the latter, don't put a swap partition on it.
    Of course, if you really wanted to have some fun, go to Wal-Mart late at night and ask the greeter if they could help you find trashbags, roll of carpet, rope, quicklime, clorox and a shovel. See if they give you any strange looks. --Streaker69

  5. #5
    Just burned his ISO
    Join Date
    Apr 2009
    Posts
    5

    Default

    Yes it is a thumb drive (flash memory). I will not put a swap partition on there. I was just wondering for my own knowledge why it is working this way.
    Thanks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •