Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: eee pc 1000he injection

  1. #1
    Just burned his ISO
    Join Date
    Apr 2009
    Posts
    8

    Default eee pc 1000he injection

    Hello,

    I am running a persistent live usb version of bt4, every time i run aireplay-ng the systems freezes and all i can do is shutdown manually.

    I looked around in this forum and on google, and i've seen people have managed to fix this by installing the new drivers for ath9k and using the mon0 interface created by airmon-ng.

    The problem is, i downloaded the tarball for compat-wireless 2.6 from here:
    wireless.kernel.org/en/users/Download#Directlydownloadingthetarball
    and ran the commands:
    #tar jxvf compat-wireless-$(date -I).tar.bz2
    #cd compat-wireless-$(date -I)
    #make
    #sudo make install
    #sudo make unload

    then rebooted the machine, and used #modprobe ath9k to load the driver.
    but the system still freezes! i can use airmon-ng and airodump-ng but aireplay-ng still freezes the system.

    I use #airmon-ng start wlan0 to start monitoring mode, and from then on i use mon0 interface for all actions (including aireplay-ng).

    any suggestions? i am kinda new to linux, so it's possible i'm installing the drivers wrong or doing something else wrong....

    Thanks

  2. #2
    Just burned his ISO
    Join Date
    Apr 2009
    Posts
    17

    Default

    check if persistent changes is setup correctly.

    instead of rebooting after installing compat-wireless, do:
    # make unload
    # modprobe ath9k

    that should work.

  3. #3
    Just burned his ISO
    Join Date
    Apr 2009
    Posts
    7

    Default

    Also had this similar problem with freezing, the newer drivers on my 1000HE with the bt4b worked awesome.

  4. #4
    Just burned his ISO
    Join Date
    Apr 2009
    Posts
    8

    Default problem compiling

    First of all, thanks for the replies.

    I think i might have found the reason the drivers didnt work...
    I had a few errors running the make command, so i guess the drivers didnt compile well. I tried searching for the problem online but i only found a few posts saying it might be a bug, but i dont think that is the case since it worked well for others...

    this is the error i get:
    root@bt:~/compat-wireless-2009-04-20# make
    make -C /lib/modules/2.6.28.1/build M=/root/compat-wireless-2009-04-20 modules
    make[1]: Entering directory `/usr/src/linux-source-2.6.28.1'
    CC [M] /root/compat-wireless-2009-04-20/drivers/net/wireless/libertas/if_sdio.o
    /root/compat-wireless-2009-04-20/drivers/net/wireless/libertas/if_sdio.c:53: error: ‘SDIO_DEVICE_ID_MARVELL_8688WLAN’ undeclared here (not in a function)
    make[4]: *** [/root/compat-wireless-2009-04-20/drivers/net/wireless/libertas/if_sdio.o] Error 1
    make[3]: *** [/root/compat-wireless-2009-04-20/drivers/net/wireless/libertas] Error 2
    make[2]: *** [/root/compat-wireless-2009-04-20/drivers/net/wireless] Error 2
    make[1]: *** [_module_/root/compat-wireless-2009-04-20] Error 2
    make[1]: Leaving directory `/usr/src/linux-source-2.6.28.1'
    make: *** [modules] Error 2


    Any suggestions?

  5. #5
    Developer
    Join Date
    Mar 2007
    Posts
    6,124

    Default

    Ok Im not sure why you are downloading new drivers. I had a friend with a 100he and in order for his to work I went into /opt/drivers which is where muts and Mister_X put the extra madwifi drivers. I built the Hal drivers and then rmmod ath_pci and modprobe ath9k and it worked p[erfect.

  6. #6
    Just burned his ISO
    Join Date
    Apr 2009
    Posts
    8

    Default

    thanks, i get an error: Module ath_pci does not exist in /proc/modules...

    what does that mean? i tried ignoring it and modprobe ath9k but it still freezes when i aireplay-ng...

  7. #7
    Junior Member
    Join Date
    Feb 2010
    Posts
    37

    Default

    Talarari i have the same problem, i froze when authenticating with my fake mac adress following xploitz video guide to cracking wep.

  8. #8
    Just burned his ISO
    Join Date
    Apr 2009
    Posts
    8

    Default help

    Does anyone know what to do with this problem?

  9. #9
    Junior Member
    Join Date
    Feb 2010
    Posts
    37

    Default

    i keep reading that the ath9k drivers are under heavy devolpment. hopefully that means that one day injection will work. until then im scouring this and the eeeuser site for updates. if anyone does find a way to run aireplay and such on a 100he please post here or link to it.

  10. #10
    Just burned his ISO
    Join Date
    Apr 2009
    Posts
    1

    Default

    Hi guys, I'm having the same problem as you trying to update the ath9k drivers in order to get the injection working.

    I had the "‘SDIO_DEVICE_ID_MARVELL_8688WLAN’ undeclared here" error, and I found one post (I'm not allowed to post the url yet) with one way to get rid of it, and I quote from there:

    Just add to your system include/linux/mmc/sdio_ids.h (from linux-headers
    package), after SDIO_DEVICE_ID_MARVELL_LIBERTAS definition:
    #define SDIO_DEVICE_ID_MARVELL_8688WLAN 0x9104
    That trick will remove the error, and you'll be able to make install the drivers.

    The bad news are that even building the drivers without error, I get another error trying loading the module with "modprobe ath9k".

    Code:
    WARNING: Error inserting cfg80211
    (/lib/modules/2.6.27-8-eeepc/updates/net/wireless/cfg80211.ko): Unknown
    symbol in module, or unknown parameter (see dmesg)
    WARNING: Error inserting mac80211
    (/lib/modules/2.6.27-8-eeepc/updates/net/mac80211/mac80211.ko): Unknown
    symbol in module, or unknown parameter (see dmesg)
    FATAL: Error inserting ath9k
    (/lib/modules/2.6.27-8-eeepc/updates/drivers/net/wireless/ath9k/ath9k.ko):
    Unknown symbol in module, or unknown parameter (see dmesg)
    and the main error on dmesg is:

    Code:
    cfg80211: Unknown symbol ksize
    ...
    (following by many others)

    I'm stuck

    Any ideas about this problem? Do you reach the same point after building the driver succesfully?

    Thanks in advance for your help guys.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •