Results 1 to 8 of 8

Thread: aireplay-ng not working , need help please

  1. #1
    Just burned his ISO
    Join Date
    Apr 2008
    Posts
    4

    Default aireplay-ng not working , need help please

    hi all,
    i got new problems new (for me),
    after i run airodump-ng --channel X --bssid xx:xx:xx:xx:xx:xx -w xxx ath0
    i found a station (client) connected and than
    i use : aireplay-ng --arpreplay -b (router mac address) -h (station mac address) ath0
    i got this error

    # aireplay-ng --arpreplay -b 00:13:F7:7C:CFF -h 00:1A:73:AE:09:06 ath0

    open(/dev/rtc) failed: No such file or directory
    The interface MAC (06:17:C4:25:EC:3B) doesn't match the specified MAC (-h).
    ifconfig ath0 hw ether 00:1A:73:AE:09:06
    14:06:02 Waiting for beacon frame (BSSID: 00:13:F7:7C:CFF)
    Saving ARP requests in replay_arp-1010-140602.cap
    You should also start airodump-ng to capture replies.

    how can i fix this problems ... thank you very much ...

  2. #2
    Member
    Join Date
    Jan 2008
    Posts
    194

    Default

    Short of telling you exactly what you did wrong, go here for more information than we could possibly give you:

    http://www.aircrack-ng.org/doku.php

    I will say, however, that I and many others (as well as tutorials) use the following for wep cracking:

    aireplay-ng -1 0 -a xx:xx:xx:xx:xx:xx ath0
    aireplay-ng -3 -b xx:xx:xx:xx:xx:xx ath0

    Enjoy your reading

  3. #3
    Just burned his ISO
    Join Date
    Apr 2008
    Posts
    4

    Default

    thx for thats url ... btw ..i use thats command before and all of command i wrote working properly ... but .. today when i try again .. come out thats error


    open(/dev/rtc) failed: No such file or director

  4. #4

    Default

    "open(/dev/rtc) failed" that happened to me before once when i compiled Aircrack-ng on Ubuntu. make sure you have the latest madwifi-ng drivers loaded and see if you can list kernal modules like so: lsmod | grep rtc and see if you can modprobe the rtc.

    if all else fails i bet you could make a quick sudo link from somewhere else, (first find it with cd /dev && find . * | grep rtc) Here is an example of where it might be:

    sudo ln -s /dev/.static/dev/rtc /dev/rtc

    Don't run that command exactly, but modify it to work with your FS/Distro.

  5. #5
    Member
    Join Date
    Jan 2008
    Posts
    194

    Default

    I just noticed on the aireplay documentation that there is a switch to disable the /dev/rtc usage:

    http://www.aircrack-ng.org/doku.php?id=aireplay-ng

    Towards the bottom it says:

    ”-R” disables /dev/rtc usage. Some systems experience lockups or other problems with RTC. This disables the usage.

  6. #6
    Just burned his ISO
    Join Date
    Nov 2008
    Posts
    5

    Default

    06:17:C4:25:EC:3B should be the number after -h

  7. #7
    Just burned his ISO su_pyrow's Avatar
    Join Date
    Jan 2010
    Posts
    11

    Default

    i hope i do not get killed/banned/castrated for this ...but this worked for me, under slackware..
    referring to
    open(/dev/rtc) failed: No such file or directory
    1. Make sure the following is enabled in your .config file
    CONFIG_RTC_LIB=m
    CONFIG_RTC_CLASS=m
    CONFIG_RTC_DRV_CMOS=m
    if those exist, then goto #3
    2. Build kernel and module
    3. Load module rtc_cmos
    modprobe rtc_cmos
    4. This will create a new file called /dev/rtc0 (252, 0)
    5. Delete or backup the existing /dev/rtc (10, 135)
    6. link or move /dev/rtc0 as /dev/rtc
    7. Done.

  8. #8
    Senior Member ShadowKill's Avatar
    Join Date
    Dec 2007
    Posts
    908

    Default

    Quote Originally Posted by su_pyrow View Post
    i hope i do not get killed/banned/castrated for this ...but this worked for me, under slackware..
    referring to
    1. Make sure the following is enabled in your .config file
    CONFIG_RTC_LIB=m
    CONFIG_RTC_CLASS=m
    CONFIG_RTC_DRV_CMOS=m
    if those exist, then goto #3
    2. Build kernel and module
    3. Load module rtc_cmos

    4. This will create a new file call /dev/rtc0 (252, 0)
    5. Delete or backup the existing /dev/rtc (10, 135)
    6. link or move /dev/rtc0 as /dev/rtc
    7. Done.
    Minus resurrecting a two month dead thread, I don't see anything wrong. Try to keep it to newer threads next time, that my only input



    "The goal of every man should be to continue living even after he can no longer draw breath."

    ~ShadowKill

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •