Results 1 to 7 of 7

Thread: keyboard problems

  1. #1
    Just burned his ISO
    Join Date
    Oct 2008
    Posts
    5

    Post keyboard problems

    hey,

    i installed bt3final in a virtual machine on my notebook ASUS B50A. In KDE i changed keyboard settings to german. Now, if i want to type a pipe, the ALTGr button only gives me a new line(same as enter). Also all 4 keypad buttons invoke a KDE snapshot but not the correct function.


    i tried the showkey -s and typed the keypad buttons:
    ==============================
    bt ~ # cat scancodes
    kb mode was RAW
    [ if you are trying this under X, it might not work
    since the X server is also reading /dev/console ]

    press any key (program terminates 10s after last keypress)...
    0x9c
    0xe0 0x2a 0xe0 0x37 0xe0 0xaa 0xe0 0xb7 #up-arrow
    0xe0 0x38 0xe0 0xb8 #left-arrow
    0xe0 0x5c 0xe0 0xdc #down-arrow
    0xe1 0x1d 0x45 0xe1 0x9d 0xc5 #right-arrow

    showkey and the buttons:
    ===============
    bt ~ # cat keycodes
    kb mode was RAW
    [ if you are trying this under X, it might not work
    since the X server is also reading /dev/console ]

    press any key (program terminates 10s after last keypress)...
    keycode 28 release
    keycode 99 press
    keycode 99 release
    keycode 100 press
    keycode 100 release
    keycode 126 press
    keycode 126 release
    keycode 119 press
    keycode 119 release

    i'm a bit confused about all these codes. anyone an idea how I set my keypad to the right function?

  2. #2
    Very good friend of the forum killadaninja's Avatar
    Join Date
    Oct 2007
    Location
    London, United Kingdom.
    Posts
    526

    Default

    /etc/X11/XF86Config

    RightAlt ModeShift

    add that line under the keyboard section
    Sometimes I try to fit a 16-character string into an 8–byte space, on purpose.

  3. #3
    Just burned his ISO
    Join Date
    Oct 2008
    Posts
    5

    Default

    no XF86 in /etc/X11

    i tried xorg.conf. there was no keyboard section. so i created one, restarted but nothing changed. thx though for your input

    i'm using ubuntu as my hostsystem. there the keypad is working correctly. is it possible to copy the keyboard configuration from ubuntu to backtrack?

  4. #4
    Very good friend of the forum killadaninja's Avatar
    Join Date
    Oct 2007
    Location
    London, United Kingdom.
    Posts
    526

    Default

    /etc/XF86Config ? Is that location there?
    Also do you have this directory /usr/lib/kbd/keytables
    Sometimes I try to fit a 16-character string into an 8–byte space, on purpose.

  5. #5
    Just burned his ISO
    Join Date
    Oct 2008
    Posts
    5

    Default

    nope, none of them.

    it's strange, i think it has something to do with vmware. i just tried to install another virtual machine (ubuntu). i can't even use the keypad to select the boot options

  6. #6
    Very good friend of the forum killadaninja's Avatar
    Join Date
    Oct 2007
    Location
    London, United Kingdom.
    Posts
    526

    Default

    research xmap.keycode
    you will need to edit your ~/.vmware/config
    Sometimes I try to fit a 16-character string into an 8–byte space, on purpose.

  7. #7
    Just burned his ISO
    Join Date
    Oct 2008
    Posts
    5

    Thumbs up

    the xmap.keycode is the solution. thanx for pointing me in that direction. i found it's a common vmware problem that occurs with several current distros.

    communities.vmware.com/message/508070#508070

    i just had to place the following lines in my ~/.vmware/config

    xkeymap.keycode.108 = 0x138 # Alt_R
    xkeymap.keycode.106 = 0x135 # KP_Divide
    xkeymap.keycode.104 = 0x11c # KP_Enter
    xkeymap.keycode.111 = 0x148 # Up
    xkeymap.keycode.116 = 0x150 # Down
    xkeymap.keycode.113 = 0x14b # Left
    xkeymap.keycode.114 = 0x14d # Right
    xkeymap.keycode.105 = 0x11d # Control_R
    xkeymap.keycode.118 = 0x152 # Insert
    xkeymap.keycode.119 = 0x153 # Delete
    xkeymap.keycode.110 = 0x147 # Home
    xkeymap.keycode.115 = 0x14f # End
    xkeymap.keycode.112 = 0x149 # Prior
    xkeymap.keycode.117 = 0x151 # Next
    xkeymap.keycode.78 = 0x46 # Scroll_Lock
    xkeymap.keycode.127 = 0x100 # Pause
    xkeymap.keycode.133 = 0x15b # Meta_L
    xkeymap.keycode.134 = 0x15c # Meta_R
    xkeymap.keycode.135 = 0x15d # Menu

    now it's working

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •