Try to run "apt-get install linux-image-2.6.39.4" without quotes. It works for me but you must have grub installed. If you get an error about update-grub, that means you haven't install grub yet. Run...