I am having a similar problem... First my armitage and framework3 weren't updating and so I had to:

apt-get remove framework3
apt-get update
apt-get upgrade ... and so on

and finally :
...