Also having the same problem and other ones:

apt-get install libroot-python-dev libboost-python-dev zlib1g-dev libssl-dev cmake libboost1.40-all-dev
Reading package lists... Done
Building...