Yes, it is.
I run BackTrack 5 32-bit GNOME on 64-bit Intel processor ;) :)
Almost all the processors that are made today are 64-bit, so BackTrack 5 has to be compatible.