I have gone through many iterations of installing ruby packages to no avail.

I'm using VMware, so I took a snapshot, then I downloaded and installed ruby-gtk2-0.16.0.lzm, ruby-libglade2-0.16.0.lzm...