When you first start warvox at the top it clearly says "this tool needs ruby 1.8 please use "update-alternatives -- config ruby" to switch" type that in and see what you get!