Hey there. This post was extremely helpful. Today I updated from 3.1.4 to 3.1.5 and the original errors came back (unable to install modules, etc, etc). Unfortunately, the patch (2.6.39) won't...