It doesn't look like anyone has suggest this option yet so I'll post it in the hope that it helps.

Doing a little reading back through what the error says when I run
dpkg --configure -a I come...