im having the exact same problem but with


nmap -sT -A --script=smb-check-vulns -PO xxx.xxx.x.xxx

on page 64 of the book...

I ran the command straight from the shell instead of metasploit...