I had the exact same problem and the solution fairly simple, you need to update apt-get and then reinstall SET:
1. apt-get update
2. apt-get install set

if that does not work out for you, else...