I'm having similar issues, but Metasploit will run for me. I'm having issues as described here concerning the pcaprub gem embedded in Metasploit (and I have not gotten the "recompile" fix described...