I'm running BackTrack 5 with Firefox 5.0.1. It's been complaining about updating. Should Firefox be updated to version 7, 6, or left at 5?

I've already went through the cycle once where I opened...