I know this is an old thread, but I thought I'd throw in my 2 cents for new users.

This error is produced by trying to open a file with just "vlc"... instead you need to use "/usr/local/bin/vlc"...