I have had the same problem, switching back to ruby 1.8 and rebuilding the mysql module worked for me.

You'll need the follwing package:


apt-get install libmysqlclient-dev

Then switch back...