Hey man, I had the same problem.What I did is apt-get purge EVERYTHING that was installed when you installed monodevelop .Once you have everything purged and the error is gone install...