I originally had this error with Metasploit so I used this fix. Now a new error appeared:

svn: In directory 'lib/gemcache/ruby/1.9.1/gems/activerecord-3.2.2/lib/active_record/connection_adapters'...