PDA

View Full Version : Ettercap 0.7.5 Install help?



Neutron
12-31-2012, 11:50 AM
Hi guys. I have BT5 r3 and I had Ettercap 0.7.4 in it which is default.

Problem is after host scanning in ettercap -G.It shuts down EVERYTIME.

I searched internet for some more info and found 0.7.5 should help.

So purge removed ettercap and tried to apt-get a newer version.

It installed me 0.7.3 so I found a link

http://sourceforge.net/projects/ettercap/files/ettercap/0.7.5-Assimilation/ettercap-0.7.5.tar.gz/download

Untar the file and start install via README which is

The easiest way to compile ettercap is in the form:
mkdir build
cd build
cmake ..
(Use ccmake . to change options such as disabling IPv6 support, add
plugins support, etc).
make install



I stuck at cmake..


root@bt:~/Downloads/ettercap-0.7.5/build# cmake ..
-- The C compiler identification is GNU
-- Check for working C compiler: /usr/bin/gcc
-- Check for working C compiler: /usr/bin/gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check if the system is big endian
-- Searching 16 bit integer
-- Looking for sys/types.h
-- Looking for sys/types.h - found
-- Looking for stdint.h
-- Looking for stdint.h - found
-- Looking for stddef.h
-- Looking for stddef.h - found
-- Check size of unsigned short
-- Check size of unsigned short - done
-- Using unsigned short
-- Check if the system is big endian - little endian
-- Looking for sys/poll.h
-- Looking for sys/poll.h - found
-- Looking for sys/select.h
-- Looking for sys/select.h - found
-- Looking for sys/utsname.h
-- Looking for sys/utsname.h - found
-- Looking for getopt.h
-- Looking for getopt.h - found
-- Looking for ctype.h
-- Looking for ctype.h - found
-- Looking for arpa/nameser.h
-- Looking for arpa/nameser.h - found
-- Looking for ltdl.h
-- Looking for ltdl.h - found
-- Looking for dlfcn.h
-- Looking for dlfcn.h - found
-- Looking for wsyncup in /usr/lib/libcurses.so
-- Looking for wsyncup in /usr/lib/libcurses.so - found
-- Found Curses: /usr/lib/libcurses.so
CMake Error at /usr/share/cmake-2.8/Modules/FindGTK2.cmake:370 (message):
Could not find GTK2 include directory
Call Stack (most recent call first):
CMakeFiles/lib_check.cmake:33 (find_package)
CMakeLists.txt:28 (include)


-- Configuring incomplete, errors occurred!


If I try make or make install



root@bt:~/Downloads/ettercap-0.7.5/build# make install
make: *** No rule to make target `install'. Stop.


Thanks for any help and happy new year.
PS:Sorry for my english

Neutron
01-03-2013, 04:07 AM
Or this is what ettercap show me after each host scanning same on 0.7.3/4


root@bt:~# ettercap -G

ettercap NG-0.7.3 copyright 2001-2004 ALoR & NaGA

Dissector "dns" not supported (etter.conf line 70)
Ooops ! This shouldn't happen...
Segmentation Fault...

Please recompile in debug mode, reproduce the bug and send a bugreport

maverik35
01-03-2013, 11:18 AM
Try using CLI..Try to avoid as much as you can GUI interfaces in Linux..It should work with no hassels..

ettercap -Tqi "iface" and add more if you try to sniff..-----> ettercap -Tqi "iface" --mitm arp:remote // /"gateway_ip"/ -P autoadd

Try it.

zimmaro
01-03-2013, 12:45 PM
[QUOTE=Neutron;232310]Hi guys. I have BT5 r3 and I had Ettercap 0.7.4 in it which is default.


-- Looking for dlfcn.h - found
-- Looking for wsyncup in /usr/lib/libcurses.so
-- Looking for wsyncup in /usr/lib/libcurses.so - found
-- Found Curses: /usr/lib/libcurses.so
CMake Error at /usr/share/cmake-2.8/Modules/FindGTK2.cmake:370 (message):
Could not find GTK2 include directory
Call Stack (most recent call first):
CMakeFiles/lib_check.cmake:33 (find_package)
CMakeLists.txt:28 (include)


-- Configuring incomplete, errors occurred!
[/CODE]

zimmaro
01-03-2013, 12:51 PM
hi :)
the installation is not successful!
I tried it on BT5-r3-kde-live-mode to install without ERRORS version 0.7.5.1 (new)
I follow these steps:
apt-get install cmake
apt-get install python-gtk2-dev libnet1-dev
NEW to download ettercap-0.7.5.1.tar.gz
tar-zxf ettercap-0.7.5.1.tar.gz
cd ettercap-0.7.5.1
cd install plug-
kwrite CMakeLists.txt
# # # add in-line sslstrip # target_link_libraries ($ {sslstrip FOUND_LIBCURL HAVE_PCRE} $ {})
save & exit
cd ..
mkdir build
cd build
cmake ..
make install
'' '/ in this mode i DONT retrive errors

test

root @ bt: ~ # ettercap

0.7.5.1 ettercap Ettercap copyright 2001-2013 Development Team


Please select an User Interface

root @ bt: ~ # ettercap-G





PS:I TESTED ONLY INSTALLATION!!
bye

Neutron
01-03-2013, 02:30 PM
Thank you so much zimmaro worked for me! and after hosts scanning no ERROR!

Just few things

By
cd install plug-

U mean
cd plug-ins

And also that sslstrip give me error even after your line update so I removed that few lines completely (But I am sure I did something wrong :P)

Anyways thanks a lot again :)

zimmaro
01-03-2013, 03:27 PM
re-hi :)
you have understood little of what I wrote before:
I made a little video for help you to "test" a installation:

https://vimeo.com/56711322

PS: I tried and it works fine! BUT I DO NOT recommend the installation (NOT being a "" backtrack-official-version "")

I hope you can help!
bye

Neutron
01-04-2013, 04:52 AM
Yep works fine in my CMakeFile the line is

target_link_libraries(sslstrip ${FOUND_LIBCURL} ${HAVE_PCRE})

which have $ on different places so I thought I should replace the line with that :)

captainrodos
01-26-2013, 02:34 PM
re-hi :)
you have understood little of what I wrote before:
I made a little video for help you to "test" a installation:

https://vimeo.com/56711322

PS: I tried and it works fine! BUT I DO NOT recommend the installation (NOT being a "" backtrack-official-version "")

I hope you can help!
bye


hi :)
the installation is not successful!
I tried it on BT5-r3-kde-live-mode to install without ERRORS version 0.7.5.1 (new)
I follow these steps:
apt-get install cmake
apt-get install python-gtk2-dev libnet1-dev
NEW to download ettercap-0.7.5.1.tar.gz
tar-zxf ettercap-0.7.5.1.tar.gz
cd ettercap-0.7.5.1
cd install plug-
kwrite CMakeLists.txt
# # # add in-line sslstrip # target_link_libraries ($ {sslstrip FOUND_LIBCURL HAVE_PCRE} $ {})
save & exit
cd ..
mkdir build
cd build
cmake ..
make install
'' '/ in this mode i DONT retrive errors

test

root @ bt: ~ # ettercap

0.7.5.1 ettercap Ettercap copyright 2001-2013 Development Team


Please select an User Interface

root @ bt: ~ # ettercap-G





PS:I TESTED ONLY INSTALLATION!!
bye
hii i have problem to give this apt-get install python-gtk2-dev libnet-dev give me back
Reading package lists... Done
Building dependency tree
Reading state information... Done
Note, selecting libnet1-dev instead of libnet-dev
libnet1-dev is already the newest version.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
python-gtk2-dev: Depends: libgtk2.0-dev (>= 2.13.6) but it is not going to be installed
E: Broken packages

what to do?? thxx

zimmaro
01-27-2013, 12:38 PM
hii i have problem to give this apt-get install python-gtk2-dev libnet-dev give me back
Reading package lists... Done
Building dependency tree
Reading state information... Done
Note, selecting libnet1-dev instead of libnet-dev
libnet1-dev is already the newest version.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
python-gtk2-dev: Depends: libgtk2.0-dev (>= 2.13.6) but it is not going to be installed
E: Broken package


what to do?? thxx

hi :)
mmm .......... missing "" "" "" 1 "" "" "" "" "ONE" "" "" " """"""EIN""""""http://www.backtrack-linux.org/forums/images/icons/icon14.png
libnet1-dev

http://imageshack.us/f/28/ettv.png/

Colatz
01-29-2013, 04:50 PM
I have the same problem, but I put:
apt-get install python-gtk2-dev libnet1-dev
HI:)

zimmaro
02-02-2013, 05:19 PM
I have the same problem, but I put:
apt-get install python-gtk2-dev libnet1-dev
HI:)

hi :) Colatz
(the place because maybe you can help someone)
as discussed in PM : this is the result of BT5-R3 KDE64 (fresh-download && fresh VM live-mode):

Osirium
02-03-2013, 08:20 PM
Hi,

I've tried to get compiled using the described steps but no luck though. I still get the sslstrip errors no matter what I've changed into the plugins CMakeList.txt file

There are two types of errors:

1. CMake Error at plug-ins/CMakeLists.txt:53 (target_link_libraries):
Cannot specify link libraries for target "$" which is not built by this
project.

about the following line: "target_link_libraries ($ {sslstrip FOUND_LIBCURL HAVE_PCRE} $ {})"

2. -- Found BISON: /usr/bin/bison
-- Found FLEX: /usr/bin/flex
CMake Error: The following variables are used in this project, but they are set to NOTFOUND.
Please set them or make sure they are set and tested correctly in the CMake files:
HAVE_PCRE
linked by target "sslstrip" in directory /home/ettercap-0.7.5.1/plug-ins

when is is used other version of "target_link_libraries" line.

Do you any thoughts about how can I get rid off this compiling error?

Thanks much.

zimmaro
02-03-2013, 08:36 PM
Hi,

I've tried to get compiled using the described steps but no luck though. I still get the sslstrip errors no matter what I've changed into the plugins CMakeList.txt file

There are two types of errors:

1. CMake Error at plug-ins/CMakeLists.txt:53 (target_link_libraries):
Cannot specify link libraries for target "$" which is not built by this
project.

about the following line: "target_link_libraries ($ {sslstrip FOUND_LIBCURL HAVE_PCRE} $ {})"

2. -- Found BISON: /usr/bin/bison
-- Found FLEX: /usr/bin/flex
CMake Error: The following variables are used in this project, but they are set to NOTFOUND.
Please set them or make sure they are set and tested correctly in the CMake files:
HAVE_PCRE
linked by target "sslstrip" in directory /home/ettercap-0.7.5.1/plug-ins

when is is used other version of "target_link_libraries" line.

Do you any thoughts about how can I get rid off this compiling error?

Thanks much.

hi :) Osirium
have you open (with-editor) CMakeLists.txt (in plu-gins-directory) & add ### "" in- line "" target_link_libraries ($ {sslstrip FOUND_LIBCURL HAVE_PCRE} $ {})
save & exit before building?
bye

Osirium
02-03-2013, 08:58 PM
@ zimmaro - Thanks so much. Next time please tell me to read carefully more than twice each of lines. I've just forget to add the bold part. ### "" in- line "" target_link_libraries ($ {sslstrip FOUND_LIBCURL HAVE_PCRE} $ {})

:)

zimmaro
02-04-2013, 08:06 AM
@ zimmaro - Thanks so much. Next time please tell me to read carefully more than twice each of lines. I've just forget to add the bold part. ### "" in- line "" target_link_libraries ($ {sslstrip FOUND_LIBCURL HAVE_PCRE} $ {})

:)

@Osirium :)
NOT .. I would never tell you to read well!! ...also..because ... I'M .."blinded"... as.. a MOLE!!!!
muahahahahahah! :)

another (FRESH & Useless) trying to install into BT5-r3 LIVE :

https://vimeo.com/58842159

bye

5star
02-13-2013, 11:07 PM
My 100% working solution on Backtrack 5r3 Gnome !!!


apt-get remove ettercap
apt-get remove ettercap-gtk
apt-get install cmake
apt-get install python-gtk2-dev libnet1-dev
apt-get install libbz2-1.0 libbz2-dev libbz2-ocaml libbz2-ocaml-dev
install PCRE http://www.linuxfromscratch.org/blfs/view/svn/general/pcre.html
install CURL http://curl.haxx.se/download.html
finaly install ettercap (see ettercap install)

Bluesman1986
02-22-2013, 08:54 PM
Hey Guys,

i was having the same issues with ettercap, mine is now working but i documented everything along the way to see if anything i did way may help others

here is a link to the post

http://www.backtrack-linux.org/forums/showthread.php?t=62083