PDA

View Full Version : Black Screen after Hard Disk Install and "startx"



Nile13
05-10-2011, 08:52 PM
Hi,
first of all, i want to say, that the Backtrack5 Version is great! Very good look and feel!

Now for my Problem: I installed Backtrack 5 - 32Bit - Gnome from my USB Stick to the Harddrive of my Laptop. After the installation (without any problems) i wanted to start the fresh installed BT. The System boots up, but after i logged in and typed in "startx", thats the end! Nothing happens anymore, i just see a black screen!

Does anybody have an idea what could be the problem.

The Laptop is an old Acer Aspire with a ATI X700 GPU.

Thanks in advance and keep up the good work!

leprkhn
05-10-2011, 10:15 PM
I had the same problem after install in the Gnome 64 version. fixed itself after installing proprietary ATI driver.

What I did:


wget http://www2.ati.com/drivers/linux/ati-driver-installer-11-5-x86.x86_64.run
sh ati-driver-installer-11-5-x86.x86_64.run

Accept license and use defaults.
Restart system.

If you don't want the proprietary driver, maybe this will work:

dpkg-reconfigure xserver-xorg

Venomous2005
05-11-2011, 03:48 AM
Leprkhn think you could help me out with a nvidia card? I downloaded the 64bit version of the driver from the official website. Closed X, then the ./run and 1/2 way through it says 'kernel source not found"

muts
05-11-2011, 05:47 AM
Check http://www.backtrack-linux.org/forums/backtrack-5-how-tos/40276-backtrack-5-how-prepare-kernel-sources-vmare-tools-drivers-etc.html

snipes420
05-11-2011, 06:47 AM
I am having a similar problem.
Acer Travelmate 5742
Intel HD Graphics

The 64-bit gnome Live DVD booted fine to the X environment.
I installed it to my hard drive. No errors.
Rebooted after to the default boot item and it booted up to a console login.
Login and try to 'startx'
The screen goes black and nothing happens.
Trying to press ctrl+alt+FX buttons doesn't switch to text virtual terminals. the system doesn't respond even to pressing the power button to initiate a power off. After a hard power off (hold the power botton) there is nothing in the /var/log/Xorg.0.log (file is 0 bytes).
Previous posters in this thread recommend installing proprietary drivers but this machine being Intel Graphics I am not able to do that.
I am thinking since the Live environment worked I will start there to track down a working configuration.

rcy999
05-11-2011, 07:06 AM
Hi,
first of all, i want to say, that the Backtrack5 Version is great! Very good look and feel!

Now for my Problem: I installed Backtrack 5 - 32Bit - Gnome from my USB Stick to the Harddrive of my Laptop. After the installation (without any problems) i wanted to start the fresh installed BT. The System boots up, but after i logged in and typed in "startx", thats the end! Nothing happens anymore, i just see a black screen!

Does anybody have an idea what could be the problem.

The Laptop is an old Acer Aspire with a ATI X700 GPU.

Thanks in advance and keep up the good work!


i installed BT5 64bit KDE , i have same problem with him

jbabtech
05-11-2011, 10:50 AM
I have the same issue. My laptop is an Acer 7741z 17' dual core with 6 gigs of ram. The boot from the 32bit cd works fine. I run the install and it also goes just fine. Once I reboot and issue startx the screen goes black and the laptop locks up. I have installed the vanilla ubuntu 10.04.2 and it has no issues what so ever. My video is the intel HD.

todumco
05-11-2011, 01:19 PM
Hi

I have the same current problems. I tried to do what is in the link above but unfortunately didn't work!


BT5
Gnome
x64

Hugs

dr_dre
05-11-2011, 02:37 PM
same problem here with gforce 310m chipset.

i might be dual head problems. ill check as soon as im behind laptop

epochwin
05-11-2011, 02:55 PM
Hey,

I got a similar problem. My laptop is the ASUS UL20FT B1. Its config is:

Intel Core i3-380UM Processor;
802.11 b/g/n wireless
12.1" HD LED Display; Intel GMA HD Graphics;


I didn't have any problem installing the latest Ubuntu 11.04 on it. Thanks in advance.

zs_ftp
05-11-2011, 03:20 PM
I get this problem in BT5-Gnome-32

snipes420
05-11-2011, 05:51 PM
I managed to get my install working using the notes in this forum thread.
http://ubuntuforums.org/archive/index.php/t-1545741.html

I added "i915.modeset=1" to my kernel command line for my intel chipset.

More information for other video chipsets may be here if its the same problem as I had. http://ubuntu4beginners.blogspot.com/2011/01/ubuntumaverick-blank-screen-problem.html

lulzapram
05-11-2011, 06:45 PM
Hmm... At first I thought that this might have been related to the fact that I have an nvidia card with optimus---Nvidia GT 335M with switchable Intel GMA 4500MHD---as this technology is unsupported by X server but many of the machines listed above do not have switchable graphics.

This issue (X server causing a kernel panic) has occurred all over the linux landscape in the past:

Lucid doesn't boot caps lock flashing: http://ubuntuforums.org/showthread.php?t=1671129
OLD BT Forum Post http://www.backtrack-linux.org/forums/old-newbie-area/13861-usb-wont-boot.html
Gentoo Forum: https://forums.gentoo.org/viewtopic-t-709850-start-0.html

My guess is that the installation somehow creates a misconfigured /etc/xorg.conf file (see https://wiki.ubuntu.com/X/Config ) because when I run BT5 live X has no problem at all starting up. When I get home from work I am going to try to create a new vanilla file with: sudo Xorg -configure . If that doesn't work, or if someone doesn't solve this for GNOME in the next few hours, I am going to try bumblee: https://github.com/MrMEEE/bumblebee which might provide a workaround to this bug for those of us who are stuck with optimus.

-E

liquid
05-11-2011, 07:06 PM
I have the same thing happening with a Dell 5510, core i5 with the Intel Corporation Core Processor Integrated Graphics Controller rev. 02.

Once you launch X, it appears the kernel panics as the scroll and caps lights start flashing and it hard locks. So I don't think its regulated to just a ATI issue, tho it is obviously a driver issue :/

Anyone else having this issue?

Edit:

I tried the Xorg -configure and created a new .conf file, no dice here with the Intel GMA. It looks like is a problem all over the landscape but it *seems* to have been fixed in the newer kernels within ubuntu (if i'm following the majority of these threads) and those are older than the current kernel being used by BT5. argh - more digging i suppose!

jbabtech
05-11-2011, 09:37 PM
For those with intel HD integrated video laptops, this is your fix. Just tried it out now and it worked. THanks snipes420 for the help!


I managed to get my install working using the notes in this forum thread.
http://ubuntuforums.org/archive/index.php/t-1545741.html

I added "i915.modeset=1" to my kernel command line for my intel chipset.

More information for other video chipsets may be here if its the same problem as I had. http://ubuntu4beginners.blogspot.com/2011/01/ubuntumaverick-blank-screen-problem.html

Snayler
05-12-2011, 04:15 AM
For those of you having trouble with starting the xorg server after a hard disk install, the following link can help. I have an old intel graphics card and it helped me.

Ubuntu 10.04 “Lucid” Blank Screen at Startup : Workaround
(http://ubuntu-tutorials.com/2010/05/06/ubuntu-10-04-lucid-blank-screen-at-startup-workaround/)

epochwin
05-12-2011, 11:44 AM
I managed to get my install working using the notes in this forum thread.
http://ubuntuforums.org/archive/index.php/t-1545741.html

I added "i915.modeset=1" to my kernel command line for my intel chipset.

More information for other video chipsets may be here if its the same problem as I had. http://ubuntu4beginners.blogspot.com/2011/01/ubuntumaverick-blank-screen-problem.html


This one worked for me. Thank You snipes420

Reamer
05-12-2011, 01:19 PM
For those with intel HD integrated video laptops, this is your fix. Just tried it out now and it worked. THanks snipes420 for the help!

I tried that and it didn't work for me. I had just put the command at the end of the kernal commands, does it HAVE to be placed before a certain command? If so, where?

I really appreciate it, I love bt5 on my netbook as everything works perfectly put of the box, but my laptop is having this problem as well.

epochwin
05-12-2011, 03:43 PM
^ The line on my grub was:

text splash nomodeset vga=791

so i changed nomodeset to i915.modeset=1 and then changed it permanently in the /etc/default/grub

You can also change the line to quiet splash i915.modeset=1

Reamer
05-12-2011, 08:12 PM
^ The line on my grub was:

text splash nomodeset vga=791

so i changed nomodeset to i915.modeset=1 and then changed it permanently in the /etc/default/grub

You can also change the line to quiet splash i915.modeset=1

Thank you so much! I'm typing this on my laptop right now. I must have been blind as a bat to not see the "text splash nomodeset vga=791." As soon as I changed it, it worked perfectly.

Just for reference, this fix was for my Intel graphics specified here from the lspci output:

VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 18)

liquid
05-12-2011, 10:28 PM
Worked for clearing up my issue with the Intel HD Graphics, thanks for the tip!

tmacuk
05-13-2011, 02:13 AM
EDIT: I HAVE FIGURED IT OUT...

as above change just the nomodeset so the line reads

text splash i915.modeset=1 vga=791

------
I am having exactly the same problem here as well. I am running Intel HD Graphics and to be more specific my lspci reads:

Intel Corporation Core Processor Integrated Graphics Controller (rev 02)

I have tried all of the above to no avail what so ever!

Anybody know of anything else to try?

bluemeda
05-13-2011, 08:12 AM
maybe this
try to change
vga=791 to
vga=792 on your
/boot/grub/grub.cfg

twisterdavemd
05-13-2011, 03:02 PM
I'm having the same issue with an Asus U50F laptop, with Intel integrated graphics. When I get some time later today, I'll try the workarounds.

secman
05-13-2011, 03:50 PM
EDIT: I HAVE FIGURED IT OUT...

as above change just the nomodeset so the line reads

text splash i915.modeset=1 vga=791

------
I am having exactly the same problem here as well. I am running Intel HD Graphics and to be more specific my lspci reads:

Intel Corporation Core Processor Integrated Graphics Controller (rev 02)

I have tried all of the above to no avail what so ever!

Anybody know of anything else to try?

I can also support the claim that i915.modeset=1 solves the problem.

twisterdavemd
05-13-2011, 04:55 PM
The fix works for the Asus U50F - many thanks!

Reamer
05-13-2011, 06:44 PM
What is the permanent fix for this? Editing my kernel on startup fixes it but editing the file /etc/default/grub doesn't. It's edited right now and if I restart without editing the kernel on boot then the X window will crash. I looked at the /boot/grub/grub.cfg file but it said not to edit it because it is generated from /etc/grub.d and /etc/default/grub. I just need to know exactly what file I need to edit in order to make this stick. Thank you.

sleepdead
05-13-2011, 09:28 PM
The i915.modeset=1 did it! For both KDE and GNOME x64!

Core i3 processor

Thank you!

Techi
05-14-2011, 05:28 AM
I have the same problem and have been trying things since the release and searching the web.

I have an HP DM4-1160US with Intel HD Graphics and a 14" wxga LED. I've tried the i915.modeset=1 and it doesn't help. Also tried changing the VGA= value because my display has a 1366X768 native resolution.

But I had no problem when I booted up on the DVD. The problem was after the install.

I also tried deleting the files mentioned in another thread in this forum that's said to be the cause for the blank screen issue but that didn't help.

I just bought this laptop on Sunday so I'm thinking about returning it and trying to find a different one.

xNeroX
05-14-2011, 03:12 PM
i had the same problem in that i could boot to backtrack as normal, however as soon as i would try to startx the screen would go black and the caps lock light would flash.

After adding i915.modeset=1 to the grub loader i now get the exact opposite problem: graphical mode works but text mode doesn't!

After grub the screen goes black straight away - however there is no kernel panic so i log in and startx as per normal (albeit without seeing what i'm typing) and then up pops gnome and everything's fine.

This is acceptable for me

I might add that im using intel HD graphics built into my i3 and also have NVIDIA Optimus GT 420 M Graphics Chipset and this combination has proved to be nothing but a royal pain in the ass

foxergod
05-15-2011, 04:56 AM
same as xNeroX, changed to i915.modeset=1 blind login and then everythings find. minor annoyance but for BT5 it seems worth it. Im on an ASUS ul80jt with i3 and NVIDIA Optimus, so seems to be a good workaround. Thanks snipes420 for posting the thread and all other for conformation.

Reamer
05-15-2011, 03:49 PM
So we have to edit the kernel line EVERY time on start-up?

Walkn
05-15-2011, 10:59 PM
Hello,

I have installed bt5 on my laptop and I have the same error "no screens found". After that I have tried to use : fix-vesa but bt said command not found...

After that I've tried to change vga=791 by vga=792 and nomodeset to i915.modeset=1 but nothing as changed...

Please could you help me to fix this issue.

freesom
05-16-2011, 02:17 PM
you don't need to edit Grub every time you boot your PC

do these steps

in your terminal but this
gksudo gedit /etc/default/grub

Find this line in that file
GRUB_CMDLINE_LINUX_DEFAULT="text splash nomodeset=1 vga=791"

change that line to
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i915.modeset=1 vga=791"

Save and close this file.

Regenerate your grub.cfg for the changes to take effect by but this code in terminal

sudo update-grub


test it with reboot

it works with me

thanks to snipes420

Walkn
05-16-2011, 08:00 PM
Hello,

Thanks for your advise but after I have changed my grub.cfg when I have restart my computer I have this message "fb: conflicting fb hw usage nouveaufb vs VESA VGA - removing generic driver" and nothing going on :(

Please could you help me.

Thanks

Reamer
05-16-2011, 10:16 PM
you don't need to edit Grub every time you boot your PC

do these steps

in your terminal but this
gksudo gedit /etc/default/grub

Find this line in that file
GRUB_CMDLINE_LINUX_DEFAULT="text splash nomodeset=1 vga=791"

change that line to
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i915.modeset=1 vga=791"

Save and close this file.

Regenerate your grub.cfg for the changes to take effect by but this code in terminal

sudo update-grub


test it with reboot

it works with me

thanks to snipes420

oh god... yet another stupid mistake. I had already edited my /etc/default/grub file but it wasn't working on boot because I didn't update grub. Thank you for reminding me about that.

ODiON
05-17-2011, 12:39 PM
solved the problem by kde x32

Chinese
05-17-2011, 06:36 PM
I had the similar problem in that i installed NVIDIA driver (I'm use BT5 KDE 32bit).

I have an ASUS A53XI241SV laptop with Intel Corporation Sandy Bridge Integrated Graphics Controller (rev 09) and NVIDIA GT 540M Graphics.(and intel core i5 Processor)

I'm tried following this(http://ubuntu-tutorials.com/2010/05/06/ubuntu-10-04-lucid-blank-screen-at-startup-workaround/) post to change my grub file.but it just changed my Screen Resolution to 1366x768,And the Screen still slow!

So i'm download the NVIDIA driver(NVIDIA-Linux-x86-270.41.06.run) from www.nvidia.com and installed.

After i "startx" there gets black screen still.but i can hear the sound of "startx"

After i del xorg.conf the "startx" back working and the screen slow not anymore.but the Transparency of the window has gone!

Does there somebody can tell me how to fix the black screen and Transparency?

mbooma
05-17-2011, 06:37 PM
you don't need to edit Grub every time you boot your PC

do these steps

in your terminal but this
gksudo gedit /etc/default/grub

Find this line in that file
GRUB_CMDLINE_LINUX_DEFAULT="text splash nomodeset=1 vga=791"

change that line to
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i915.modeset=1 vga=791"

Save and close this file.

Regenerate your grub.cfg for the changes to take effect by but this code in terminal

sudo update-grub


test it with reboot

it works with me

thanks to snipes420

not working for me

HP DV7 : i5 with ATI HD 5650

todumco
05-18-2011, 01:06 AM
Hi folks

Only warning: I installed KDE 32 bits. Gave the same problem of black screen. I followed the above tips and it worked!

My computer is a Dell laptop n5010 15r.

Some data obtained with the command lshw and lspci-vv


*-cpu:0
description: CPU
product: Intel(R) Core(TM) i5 CPU M 480 @ 2.67GHz
vendor: Intel Corp.
physical id: 4
bus info: cpu@0
version: 6.5.5

================

*-memory
description: System Memory
physical id: 1d
slot: System board or motherboard
size: 6GiB


===============

Network controller: Intel Corporation WiFi Link 6000 Series (rev 35)
Subsystem: Intel Corporation Device 1321
Kernel driver in use: iwlagn
Kernel modules: iwlagn

==============

Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 02)
Subsystem: Dell Device 0447
Kernel driver in use: r8169
Kernel modules: r8169

Congratulations to you all ;)

Hugs :D

maniac360
05-18-2011, 11:49 AM
i have a dell 15r i5 480 with hd5670 and when i change the line in the grub.cfg it doesnt change anything. With my desktop i cant even use startx it says "warn radeon... failed to alocate". Even with virtual box on seven it doesn't work. But on virtualbox on ubuntu it works.

pgz05
05-19-2011, 12:12 PM
Hi I have a Sony Vaio Z VPCZ1290s with Intel HD graphics 1920x1080 resolution. Im having the same problem with it when installing BT5 Gnome64bit. The only way I could get into the terminal is with the nomodeset parameter but when I startx the screen goes black and the caplock LED start flashing. I tried the i915.modeset=1, i915.modeset=0, changing the vga=1 to 2 in the grub menu but the screen would still go black after a few moments. Does anyone have other solutions?

Azphael
05-19-2011, 03:43 PM
Hello Guys,


Same problem but i can't even install BT 5 Gnome 32. If i choose the first option the menu of the live cd my screen go black and the caps lock start blinking, i was already givin up and i tried the option no DRM and then i could get to the prompt but if i run startx scren goes black again. I tried a lot of commands already
"cp /etc/xorg.conf.failsafe /etc/x11/xorg.conf " result -> didn't find xorg.conf.failsafe...

anybody knows how to fix that black screen issue ?

maniac360
05-19-2011, 08:26 PM
http://www.backtrack-linux.org/forums/backtrack-5-fixes/40286-bt5-kde-64bit-startx-problem.html

rokessler
05-21-2011, 07:03 AM
This solved the problem for me (BT5 Gnome 64bit on 2010 27" iMac with ATI Radeon HD 5700):

# wget http://www2.ati.com/drivers/linux/ati-driver-installer-11-5-x86.x86_64.run
# chmod +x ati-driver-installer-11-5-x86.x86_64.run
# ./ati-driver-installer-11-5-x86.x86_64.run
# reboot
# aticonfig --initial
# startx

Thanks a lot!

Cheers,
Roland

GNic24
06-04-2011, 04:37 PM
I have an HP DM4 with Intel HD Graphics. I'm running BT5-32 GNOME and was experiencing the same problem. Leaving the Grub configuration normal (nomodeset) I am able to get to the splash screen where I have to unlock my drive ( full encryption ) and then login but startx leads to a kernal panic, black screen and blinking caps lock. After changing my grub to i915.modeset=1 I get a black screen as soon as it boots, no splash or unlocking, or login. But what I found out is that it is still running I simply can't see it, I wait until the activity light on my flash drive stops blinking and then type in my login, and then issue startx and it starts up just fine! I don't know why I can't see the text at boot or splash screen and its kind of a pain but worth it.

Hope this helps someone else!

original
06-05-2011, 12:00 PM
I have the same thing happening with Intel(R) G41 Express Chipset (graphic card)
and
Ensoniq Audio PCI ENS 1371 (ES1371 DAC2/ADC) in BT5 KDE 32
help me please

zyjsuper
06-07-2011, 02:36 AM
Try to enter recovery mode and recreate xorg.conf!!:D

original
06-07-2011, 12:06 PM
Try to enter recovery mode and recreate xorg.conf!!:D
haw i can recreate xorg.conf can you help me please
can you give me instructions for this if you can

Ghanthor
06-08-2011, 09:46 PM
For those of you having trouble with starting the xorg server after a hard disk install, the following link can help. I have an old intel graphics card and it helped me.

Ubuntu 10.04 “Lucid” Blank Screen at Startup : Workaround
(http://ubuntu-tutorials.com/2010/05/06/ubuntu-10-04-lucid-blank-screen-at-startup-workaround/)

1 word: Beautiful!!!! Tnx
Dell D400 up with x on HD install.

darkoptx
06-11-2011, 11:15 PM
quiet splash i915.modeset=1 vga=791
Does work fine on my Acer 5742G with the 32bit KDE
Thx for that

STAT1CV01D100
06-15-2011, 07:03 PM
no doubt this will work for you, it did for me!
print this out and type it in after your user name and password

rm /root/.kde/cache-root/icon-cache.kcache
rm /root/.kde/cache-root/plasma_theme_Volatile.kcache
rm /root/.kde/cache-bt/icon-cache.kcache
rm /root/.kde/cache-bt/plasma_theme_Volatile.kcache
startx


voila! :)

Yurius
06-17-2011, 07:01 PM
Hello,

Excuse me for my English, I'm French and I'm not sure that all I say will be comprehensible.

So I explain my issue.

I have install BT5 on my Eeepc in dual boot with Windows XP.
The install was correctly done despite blackscreen when booting Live CD. I fix that with the command line "i915.modeset=1" and now BT work perfectly.
But when I launch Windows XP, I have a black screen. The system boot because I can see the loading bar and I hear the starting sound.

If someone can Help me, please.

Also, Here my grub.conf file. I try to edit the custom entry but without success.


#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by /usr/sbin/grub-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#

### BEGIN /etc/grub.d/00_header ###
if [ -s $prefix/grubenv ]; then
load_env
fi
set default="0"
if [ ${prev_saved_entry} ]; then
set saved_entry=${prev_saved_entry}
save_env saved_entry
set prev_saved_entry=
save_env prev_saved_entry
set boot_once=true
fi

function savedefault {
if [ -z ${boot_once} ]; then
saved_entry=${chosen}
save_env saved_entry
fi
}

function recordfail {
set recordfail=1
if [ -n ${have_grubenv} ]; then if [ -z ${boot_once} ]; then save_env recordfail; fi; fi
}
insmod ext2
set root='(hd1,6)'
search --no-floppy --fs-uuid --set a6aa2dc1-4e48-4bec-86b3-d30dddae0d0b
if loadfont /usr/share/grub/unicode.pf2 ; then
set gfxmode=1024x768
set gfxpayload=keep
insmod gfxterm
insmod vbe
if terminal_output gfxterm ; then true ; else
# For backward compatibility with versions of terminal.mod that don't
# understand terminal_output
terminal gfxterm
fi
fi
insmod ext2
set root='(hd1,6)'
search --no-floppy --fs-uuid --set a6aa2dc1-4e48-4bec-86b3-d30dddae0d0b
set locale_dir=($root)/boot/grub/locale
set lang=en
insmod gettext
if [ ${recordfail} = 1 ]; then
set timeout=-1
else
set timeout=10
fi
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/05_debian_theme ###
set menu_color_normal=white/black
set menu_color_highlight=black/light-gray
### END /etc/grub.d/05_debian_theme ###

### BEGIN /etc/grub.d/10_linux ###
menuentry 'Ubuntu, with Linux 2.6.38' --class ubuntu --class gnu-linux --class gnu --class os {
recordfail
insmod ext2
set root='(hd1,6)'
search --no-floppy --fs-uuid --set a6aa2dc1-4e48-4bec-86b3-d30dddae0d0b
linux /boot/vmlinuz-2.6.38 root=UUID=a6aa2dc1-4e48-4bec-86b3-d30dddae0d0b ro text splash nomodeset vga=791
initrd /boot/initrd.img-2.6.38
}
menuentry 'Ubuntu, with Linux 2.6.38 (recovery mode)' --class ubuntu --class gnu-linux --class gnu --class os {
recordfail
insmod ext2
set root='(hd1,6)'
search --no-floppy --fs-uuid --set a6aa2dc1-4e48-4bec-86b3-d30dddae0d0b
echo 'Loading Linux 2.6.38 ...'
linux /boot/vmlinuz-2.6.38 root=UUID=a6aa2dc1-4e48-4bec-86b3-d30dddae0d0b ro single
echo 'Loading initial ramdisk ...'
initrd /boot/initrd.img-2.6.38
}
### END /etc/grub.d/10_linux ###

### BEGIN /etc/grub.d/20_memtest86+ ###
menuentry "Memory test (memtest86+)" {
insmod ext2
set root='(hd1,6)'
search --no-floppy --fs-uuid --set a6aa2dc1-4e48-4bec-86b3-d30dddae0d0b
linux16 /boot/memtest86+.bin
}
menuentry "Memory test (memtest86+, serial console 115200)" {
insmod ext2
set root='(hd1,6)'
search --no-floppy --fs-uuid --set a6aa2dc1-4e48-4bec-86b3-d30dddae0d0b
linux16 /boot/memtest86+.bin console=ttyS0,115200n8
}
### END /etc/grub.d/20_memtest86+ ###

### BEGIN /etc/grub.d/30_os-prober ###
menuentry "Windows NT/2000/XP (on /dev/sda1)" {
insmod ntfs
set root='(hd0,1)'
search --no-floppy --fs-uuid --set D004352F04351A44
drivemap -s (hd0) ${root}
chainloader +1
}
### END /etc/grub.d/30_os-prober ###

### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries. Simply type the
# menu entries you want to add after this comment. Be careful not to change
# the 'exec tail' line above.
menuentry "Windows NT/2000/XP (on /dev/sda1)" {
insmod ntfs
set root='(hd0,1)'
search --no-floppy --fs-uuid --set D004352F04351A44 vga=791
drivemap -s (hd0) ${root}
i915.modeset=1
chainloader +1
}


### END /etc/grub.d/40_custom ###

xxjsofxx
06-20-2011, 03:39 AM
Hi Everyone,

I'm having the same issue,

I can't proceed with the installation process. i can't even go to the 'Install BackTrack" portion. I'm stuck at the "root@root:~#" and every time i type startx the screen goes black and capslock keep flashing. I have tried editing the grub but I can't grup-update since it is in the Live CD.

I'm using MSI FX400x-i3885 with 2 GPUs, intel core i3. Tried both KDE and GNOME 64bit but same problem. I have posted my concern http://www.backtrack-linux.org/forums/backtrack-5-beginners-section/42079-startx-problem-msi-fx400x-i3885.html but none is replying yet.

what should i do? anyone please,



thanks in advance.
jsof

cogeary01
06-28-2011, 10:11 PM
I had similar problems with such a black screen whenever I logged out and when I tried to sudo startx on an account that couldn't sudo.

I installed the driver for my video card (ATI Mobility Radeon HD 5700) and it works perfectly now.

Souless
07-03-2011, 04:39 PM
ok so for those of you guys that have issues with launch startx and x-windows crashing try this:

cd /root/.kde/
find . -type f -iname "*.kcache" -delete
startx

For the guys that cant even see the console after booting and they just get a blank screen try this:

when the grub boot screen comes up hit "e" for edit mode
and you should see something similar to this (note this will vary):

recordfail
insmod ext2
set root='(hd1,6)'
search --no-floppy --fs-uuid --set a6aa2dc1-4e48-4bec-86b3-d30dddae0d0b
linux /boot/vmlinuz-2.6.38 root=UUID=a6aa2dc1-4e48-4bec-86b3-d30dddae0d0b ro text splash nomodeset vga=791
initrd /boot/initrd.img-2.6.38

The line to be concerned with here is the:

linux /boot/vmlinuz-2.6.38 root=UUID=a6aa2dc1-4e48-4bec-86b3-d30dddae0d0b ro text splash nomodeset vga=791

change it to look like this at the end:

linux /boot/vmlinuz-2.6.38 root=UUID=a6aa2dc1-4e48-4bec-86b3-d30dddae0d0b ro quiet splash i915.modeset=1 vga=791

you are just changing "text" to "quiet" and "nomodset" to "i915.modset.modeset=1"

then hit ctrl-x to boot

See if that works. If so you can make the changes permanent by editing /etc/default/grub file with the changes above.
Change:
GRUB_CMDLINE_LINUX_DEFAULT="text splash nomodeset vga=791"
to
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i915.modeset=1 vga=791"

Then at a terminal type:
update-grub

reboot and see your new display.

b1tsp4rk
07-14-2011, 02:17 PM
;) Hi friends...

at first... sorry by my english... i'm a brazillian one...

Ok... i've tried each topic of this forum...

I have a DELL VOSTRO 3300 with Intel Graphics card i915.

I'm using BT5 64bits with GNOME. To solve my problem was very simple... i just removed every thing between the quotes ("") in the line "GRUB_CMDLINE_LINUX_DEFAULT"... I know... it's strange... but it's working right now... i'll attach here a copy of my /etc/default/grub file...

PLEASE!!! DON'T FORGET TO RECOMPILE THE GRUP AFTER CHANGE THE GRUB FILE... do this with the command "update-grup"

follow the grub file...

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT=""
GRUB_CMDLINE_LINUX=""

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE=1366x768

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
1,1 Top


I really hope to help...
please... make contact with e-mails... I'm starting with BT... and hope to share some knowledge!!!

inrikey
08-13-2011, 12:19 PM
hey guys i solved the 1st problem of no csreen found simply by typing ''fixvesa'' befor the ''startx'' it will boot normal but i have another problem now it's the wifi ( i'm booting from usb ) so the wifi on my laptop Dell inspiron n5010 core i3 had the Broadcom with bluetooth integrated so back to the problem that backtrack only show that i have lan but no wifi on my laptop.any help would be apreciated :)

kirsikas
08-25-2011, 08:17 PM
This solved the problem for me (BT5 Gnome 32bit on HP ELiteBook 8440p, NVIDIA NVS 3100 graphics with 512 MB dedicated gDDR3 video memory
Intel® HD Graphics):

GRUB_CMDLINE_LINUX_DEFAULT="text splash nomodeset vga=791"
to
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i915.modeset=1 vga=792"

Then at a terminal type:
update-grub

gabo181
08-31-2011, 01:35 AM
I am having a similar problem.
Acer Travelmate 5742
Intel HD Graphics

The 64-bit gnome Live DVD booted fine to the X environment.
I installed it to my hard drive. No errors.
Rebooted after to the default boot item and it booted up to a console login.
Login and try to 'startx'
The screen goes black and nothing happens.
Trying to press ctrl+alt+FX buttons doesn't switch to text virtual terminals. the system doesn't respond even to pressing the power button to initiate a power off. After a hard power off (hold the power botton) there is nothing in the /var/log/Xorg.0.log (file is 0 bytes).
Previous posters in this thread recommend installing proprietary drivers but this machine being Intel Graphics I am not able to do that.
I am thinking since the Live environment worked I will start there to track down a working configuration.


i have the same problem.
i got a hp 206la
intel hd graphics

i tried to run the gnome 64 bit version.

Tools
09-14-2011, 11:29 PM
quiet splash i915.modeset=1 works on Dell R15. Thanks!

userpasta
10-05-2011, 01:58 AM
i have the same problem.
i got a hp 206la
intel hd graphics

i tried to run the gnome 64 bit version.

After installing BT5 you should've one that: http://www.backtrack-linux.org/forums/backtrack-5-bugs/40224-black-screen-after-hard-disk-install-startx-4.html#post197240

wackky86
10-27-2011, 06:26 PM
hey guys,i am having problem installing backtrack 5 on my hdd,i want dual boot it with my windows 7 ultimate 64-bit,the problem i am facing is that while booting backtrack 5 i can see the whole thing loading but after some secs the whole screen goes black,i cant even see the startx screen...its black before that only,now after a lot of searching i came to know that its a graphics issue,i came to know that i have to disable my graphics but in my bios i cant find any option regarding the graphics card,i am using dell inspiron n4110 laptop with switchable graphics ATI Radeon HD 6470 and Intel HD Graphics 3000,i3 2.xx ghz 2nd gen processor,3gb ddr3 RAM

Please guys help me out installing backtrack 5 Gnome,64/32 bit anything will do..just want to install it,please help me out!!

AvengedPie
11-10-2011, 06:19 AM
After a week of frustration, yelling, threatening my laptop, and copious amounts of alcohol and drug usage to make me feel normal again, I finally got it installed. I just wanted to thank everyone for their input, suggestions, and effort to help n00bs like me get our foot in the door. For the record it was this link (http://ubuntu-tutorials.com/2010/05/06/ubuntu-10-04-lucid-blank-screen-at-startup-workaround/) that helped me out. So yeah... just wanted to say thank you for everybody who posted a suggestion, you're good people.

Snayler
11-10-2011, 03:06 PM
Please note that the i915.modeset=1 parameter is only used for intel graphics cards.


nomodeset alternatives for other Graphic Cards:

According to our senior member oldfred at ubuntuforums.org, you need to replace nomodeset with some other parameters for different cards.

Older Intel video card: i915.modeset=1 or i915.modeset=0
nVidia: nomodeset
Generic: xforcevesa or nouveau.modeset=0
Radeon: radeon.modeset=0

Replace nomodeset with the appropriate parameter from listed one's.

From here (http://www.tuxgarage.com/2011/01/ubuntumaverick-blank-screen-problem.html).

saumitramallick
11-11-2011, 02:50 PM
need some immidiate assistance,,,,i have previously windows 7 on my laptop,,,,with three partition one for 7 and other two were ntfs(dynamic) partition for storing data
c: window partition 36 gb
d: dynamic part 80gb
e: dynamic partition rest of my hdd
i removed win 7 and installed backtrack5 r1 the os is running properly but there is a problem with my dynamic partition
when i run fdisk-l it gives the following op
root@bt:~# fdisk -l

Disk /dev/sda: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x944a0823

Device Boot Start End Blocks Id System
/dev/sda1 * 1 5145 41325569 5 Extended
/dev/sda4 5146 38914 271242987+ 42 SFS
/dev/sda5 1 4521 36307968 83 Linux
/dev/sda6 4521 5145 5016576 82 Linux swap / Solaris

i tried mounting the sda4 partition by typing
sudo mount -t ntfs /dev/sda4 /media/sda4 -o defaults,umask=04
NTFS signature is missing.
Failed to mount '/dev/sda4': Invalid argument
The device '/dev/sda4' doesn't seem to have a valid NTFS.
Maybe the wrong device is used? Or the whole disk instead of a
partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?

Maybe the wrong device is used? Or the whole disk instead of a
partition
do make sense because backtrack just merged my d: & e: partition
another problem is the sda4 partition is sfs not ntfs
ie/dev/sda4 5146 38914 271242987+ 42 SFS
i have very important data in these drives ,,,so i want to recover it ,,, please someone do help me

Snayler
12-11-2011, 12:51 AM
Install windows (or boot it from USB), save all your data to an external HDD and format the partition causing problems, preferably to NTFS (no dynamics nor SFS, whatever that is). This seems like your only option, because from what I've red in my quick research, Ubuntu doesn't support SFS (BT5 is based on Ubuntu...).

saumitramallick
12-11-2011, 11:06 AM
Install windows (or boot it from USB), save all your data to an external HDD and format the partition causing problems, preferably to NTFS (no dynamics nor SFS, whatever that is). This seems like your only option, because from what I've red in my quick research, Ubuntu doesn't support SFS (BT5 is based on Ubuntu...).

hey thnxx for reply ,,, bt i've troubleshooted it with HBCD a few days ago,,,
the actual problem was that I've lost my partition tables for ntfs system and due to sfs file system i was unable to access it ,,
so i did recovered it by booting in mini xp,,,and recovering the partition tables and backup all my data
so now its all fine ,,,,

kiowa50161
12-17-2012, 07:17 PM
I just fixed mine with BTr3. When you come to the splash create where you choose your boot environment press 'tab' then in the text field it creates simply type in i915.modeset=1 then press enter. It'll begin your typical black/text boot up and will get to root@bt. Then you can do 'startx' and you will get to the desktop.

glili3a
12-24-2012, 04:38 PM
The problem is :
/boot/grub/grub.cfg
Open file grub.cfg and find a line like this :
linux /boot/vmlinuz-2.6.38 root=UUID=1ecd35a8-0437-4c37-b*b72-63d014dd846e ro text splash nomodeset vga=791
Yes it's the problem, field vga not yet set.
Fixed
You can replace the line with :
linux /boot/vmlinuz-2.6.38 root=UUID=1ecd35a8-0437-4c37-b*b72-63d014dd846e ro text splash vga=0x791
You can do it through the console, before you type "startx" or with linux booting.
Have fun!

breadfan
01-22-2013, 07:13 PM
for those who have problems with their lenovo T410 in installing BT5.0 KDE 32bit, go to my post here:
[GUIDE] Loading the i915 driver in the 3.2.6 kernel without adding unsupported PPA's
I used the info from this post though.
thank you guys for sharing with the knowledge.
take care!